Systémové požadavky

<< Klikni pro zobrazení obsahu >>

Navigace:  Webová aplikace > Instalace webové aplikace >

Systémové požadavky

Připravuje se.

 

 

Celá webová aplikace musí být umístěna přímo na Vašem serveru u Vás ve škole. Nejlépe přímo na serveru, na kterém máte nainstalovány Bakaláře. Všichni uživatelé se připojují přímo na Vaši školu. Provoz na hostingu je ve velmi omezené míře možný, ale velmi ho nedoporučujeme (ochrana dat, aktualizace atd.).

Co je nutné mít předem nainstalováno

Windows 2008 server, Windows 2012 server, Windows 2016 server, Windows 7 Professional a vyšší (s omezením), Windows 7 Professional. V současné době doporučujeme zvolit systém Windows 2008 server a vyšší buď 32bitový nebo 64bitový. Nedoporučujeme používat 64bitové verze serverů, pokud máte data uložena v DBF souborech, ale za určitých podmínek (nejsou na serveru další role jako WSUS nebo Exchange) lze webaplikaci zprovoznit i zde (nastavení na Windows 2008). Při uložení dat na SQL server nebyly nalezeny žádné zásadní problémy s provozem.

Internet Information Services (IIS) verze 5.0 nebo vyšší. Toto je vlastní webový server. Vždy postačuje ta verze, která je přímo obsažena v instalaci té verze serveru Windows, které používáte. Pokud ji nemáte nainstalovanou, stačí v buď v Ovládacích panelech - Instalace programů vstoupit do sekce Přidat či odebrat součásti Windows a tam najít příslušnou položku Internetová informační služba nebo u Windows serveru přidat role aplikační a webová služba.

.NET Framework verze 4.5. Pokud není již příslušná verze frameworku přítomna přímo v serveru, lze instalaci stáhnout z Internetu (www.microsoft.com - zde najdete i nejnovější updaty). Instalace je velká cca 24MB a nainstaluje do vašeho systému podporu moderních .NET technologií. Instalace je bezproblémová, daný produkt je volně šiřitelný. Až do verze 07/08 bylo nutné pro správný běh aplikací používat verzi 1.1. Od verze 08/09 je bylo nutné používat verzi 2.0. Od verze 12/13 je nutné používat verzi 4.0. Od verze 15/16 je nutné používat verzi 4.5.

program Bakaláři včetně Webové aplikace + všechny aktualizace (nebo vyšší verze). Doporučujeme mít stále nejaktuálnější verzi, protože vývoj web aplikace je v současné době opravdu rychlý a mnohé vlastnosti a nové součásti této aplikace přibývají i během roku jako standardní aktualizace.